UPDATE 06/28/2020: Am reclaiming Media Library space by deleting old pics.

**********************************************************

I’ve lost confidence in Linux Mint over the past year…hard to put a finger on why, but have a ‘Gut Feeling’ that there is more turmoil going on inside the ‘Mint Team’ than they are letting us know about. I mention the problems and my suspicions in the ‘Linux Mint still struggling – is Ubuntu Cinnamon Remix prepping to ‘Step-in’ and/or ‘Step In’?’ post. Also, there have been ‘whispers’ about the ‘Mint Team’ moving away from the actual OS development aspects of Mint, and focusing more on the actual Cinnamon DE development. I don’t know, but that ‘Ubuntu Cinnamon Remix’ sure came out of nowhere with a huge jump.

For now, I am leaving Mint as the #4 on my Top 10 Distro list, but I am not confident in that ranking anymore. Enough said, and on to today’s Linux Mint 19.3 “Tricia” Cinnamon tests – using the ‘Antec Sr.’ computer.

Took 3 attempts before I got it to install … am not sure why. Here are some pics:

 

 

No “CD/DVD” was involved in the installation, and the test 128GB SSD had just been used yesterday and thoroughly reformatted with GParted yesterday. I didn’t catch a pic of the 1rst failure, because I was caught off guard by Mint failing at an installation. Had GParted reformat again, since the installation process had prepped the disk just before failure. Those above 2 pics are from the second failure. Maybe something about the ‘Live’ USB was causing a problem, so I moved it to a 2.0 USB port, and put Ubuntu and WIN10 onto fixing that 128GB SSD. Since the test 128GB SSD always gets reformatted back to the NTFS format on Ubuntu using GParted, I started there again…checked the disk, and no problems. Then I moved it over to WIN10 and used Disk Management to delete it again, assign a Drive Letter and once again reformat the drive to NTFS. Closed Disk Management, and opened the This PC folder to perform a Disk check and to Optimize the drive. Everything looked OK, so went back to ‘Antec Sr.’ and the installation…it worked this time, and here are the pics:

 

That window only showed up in the 2nd install attempt…I have no clue why it didn’t show up in the 2 other attempts. I next selected install third-party software:

 

Then selected Erase disk and install Linux Mint:

 

Name and password, then continue:

 

Installation went great the 3rd time:

 

Nice DE, and I like the Logo without that former distracting brightly colored one. Here is an info pic:

 

Everything looks great. Have already done a full update to the SSD installation, so will test it on ‘Apevia’ and the Ryzen™ APU:

 

Am not sure if Linux gets the full AMD Radeon™ RX Vega 11 Graphics driver, but the one they use seems to work OK. Overall, Mint is another good choice for Windows 7 users to test, and it does have that Windows look panel.

Rule of Thumb – if you can’t install Ubuntu on it, then you can’t install any Linux Distro on it.